Abhängigkeitsproblem beim installieren von Git auf CentOS 6.2

Vorhin wollte ich Git auf einer CentOS 6.2 – Maschine installieren. Dabei kam es allerdings zu folgendem Problem:

# yum install git
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * epel: nl.mirror.eurid.eu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.4.1-1.el5 will be installed
--> Processing Dependency: perl-Git = 1.7.4.1-1.el5 for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: perl(Git) for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: libexpat.so.0()(64bit) for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.7.4.1-1.el5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: git-1.7.4.1-1.el5.x86_64
--> Running transaction check
---> Package compat-expat1.x86_64 0:1.95.8-8.el6 will be installed
---> Package git.x86_64 0:1.7.4.1-1.el5 will be installed
--> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.7.4.1-1.el5.x86_64
---> Package openssl098e.x86_64 0:0.9.8e-17.el6.centos.2 will be installed
---> Package perl-Git.x86_64 0:1.7.4.1-1.el5 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-Git-1.7.4.1-1.el5.x86_64
--> Finished Dependency Resolution
Error: Package: git-1.7.4.1-1.el5.x86_64 (epel)
           Requires: libcurl.so.3()(64bit)
Error: Package: perl-Git-1.7.4.1-1.el5.x86_64 (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)

Man sieht es gab insgesamt zwei Probleme. Zum einen wird curl, zum anderen das Compar, benötigt. Nach einer Prüfung stellte sich raus das beide Module funktional unter /usr/sbin installiert waren – komisch.

Ein anderes Problem war das Folgende:

There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.

yum-complete-transact gibt es allerdings nicht (command not found). Im Internet las ich allerdings, das oft die nicht installierten yum-utils Schuld sein könnten. Dies führte letztlich auch zum Ziel:

yum install yum-utils

Trotzdem erschienen noch die gleichen Fehler wie am Anfang. Die Lösung ist nämlich git ohne die EPEL-Repos zu installieren. Gesagt getan..

yum install git --disablerepo=epel

.. so lässt sich das ganze dann nämlich sauber mit yum installieren. Ich hoffe das kann einigen die via Google hierher gefunden haben weiterhelfen.

Update vom 05.10.2012:

Die Git / Perl – Abhängigkeiten vertragen sich irgendwie nicht mit yum update. Dies lässt sich aber leicht mit dem hinzufügen der folgenden Zeilen in die Datei /etc/yum.repos.d/epel.repo beheben:

[epel]
name=Extra Packages for Enterprise Linux 5 - $basearch
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
exclude=perl* git*

So kann man yum dazu bringen das die EPEL-Repo für die angesprochenen Pakete nicht nach Updates durchsucht wird.

Flattr this!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.